Billing Provider Degradation of Service
Incident Report for Formstack
Resolved
Zuora’s degradation of service has been resolved; current billing functionality has been restored. Please try to execute the previous billing service again. Thank you.
Posted Apr 17, 2023 - 12:06 EDT
Monitoring
Zuora (Formstack’s billing provider) is having a degradation of service, as a result, your account’s administrative billing function is currently nonfunctional.

Our teams are monitoring the billing provider’s site for updates and resolution.

Description/Impact: You will receive a 500 error page when you try to do any of the following: change your plan, update a credit card, and view invoices.

Next Steps: We will continue to monitor the billing provider’s status. Once it has been restored, please retry the billing process again.

We apologize for any inconvenience this has caused and thank you for your patience. We will provide further updates as soon as they are available.
Posted Apr 17, 2023 - 11:15 EDT
This incident affected: Formstack Sign (Billing Portal), Formstack Documents (Billing Services), Formstack Forms (Billing Portal), Zuora Production API, Formstack for Salesforce (Billing Portal), and Formstack Forms - Third Party Integrations (Billing Services).