Forms returning 502 error
Incident Report for Formstack
Resolved
The Forms application had severeley diminished performance from approximately 5:04am to 5:22am Eastern this morning. We have implemented a solution to this now and it is performing as expected.
Posted Sep 05, 2023 - 05:55 EDT
Monitoring
We have identified the issue and have implemented a solution. Access to your Formstack account and forms has been fully restored. We will continue to monitor this activity and will share more details regarding this incident.
Posted Sep 05, 2023 - 05:27 EDT
Investigating
We are currently experiencing a service disruption impacting Forms. Our Development teams are working to identify the root cause and implement a solution. We will be posting additional status updates as soon as they come in.
Posted Sep 05, 2023 - 05:25 EDT
This incident affected: Formstack Forms (Main Application, Forms (Hosted & Embedded)).