Forms workers not running - integrations and emails delayed
Incident Report for Formstack
Resolved
Workers servers have been fully restored and all queued jobs have been completed as expected. Data and events were delayed for up to 1 hour, and no data loss occurred.
Posted Jan 17, 2024 - 18:40 EST
Identified
We have identified the issue and are working toward a solution. Resolution expected within 30 minutes.
Posted Jan 17, 2024 - 18:03 EST
Investigating
As of 17:25 Eastern, Forms workers are delayed and queues are backing up. This affects form analytics, submit-action events like form integrations, submission exports, and emails. The Forms application, and the live form is functioning properly.
Posted Jan 17, 2024 - 17:25 EST
This incident affected: Formstack Forms - Third Party Integrations (Salesforce, Google Sheets, HubSpot, Amazon S3, Google Calendar, Google Drive, Formstack Documents, Zendesk, Webhooks) and Formstack Forms (Email System (SendGrid)).