Unable to Login to Forms application
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 10:39 EST
Monitoring
Reports of login related issues have subsided. Our team will continue to monitor this issue throughout the evening.
Posted Jan 13, 2022 - 18:54 EST
Update
We are continuing to investigate this issue.
Posted Jan 13, 2022 - 17:25 EST
Investigating
We are currently investigating an issue where users are unable to log into Formstack applications. Our team is actively working toward a resolution now, apologies for any inconvenience.
Posted Jan 13, 2022 - 17:15 EST
This incident affected: Formstack Forms (Main Application), Formstack Sign (Main Application), and Formstack Documents (Website & Management Portal).