AWS Errors Impacting Formstack Application Performance
Incident Report for Formstack
Resolved
AWS has reported that this incident is now resolved. Please visit https://status.aws.amazon.com/ for incident details.
Posted Dec 08, 2021 - 08:26 EST
Update
The AWS team continues to actively work toward full resolution of this issue and mitigation efforts have already yielded positive results. While things are still being worked out Formstack users may experience intermittent problems using our applications.

For additional information on this incident please refer to: https://status.aws.amazon.com/
Posted Dec 07, 2021 - 17:17 EST
Monitoring
AWS is currently experiencing increased errors in the US-EAST-1 region, which in turn is impacting Formstack applications. For details and updates on this problem please reference AWS status page: https://status.aws.amazon.com/
Posted Dec 07, 2021 - 11:43 EST
This incident affected: Formstack Forms (Main Application) and Formstack Sign (Main Application).