Forms - Google Sheets integration moving slowly
Incident Report for Formstack
Resolved
Through the night, Google Sheets integrations continued to move slowly, and as of 01:05am Eastern on September 28th, all messages had been processed
Posted Sep 28, 2023 - 07:54 EDT
Investigating
The Google Sheets submission integration on Forms is performing very slowly at this time. We are processing active submissions into Google Sheets at regular speed. However, a "re-run" of an integration is being delayed by a number of hours. We expect this to be resolved overnight Sept 27th.
Posted Sep 27, 2023 - 18:17 EDT
This incident affected: Formstack Forms - Third Party Integrations (Google Sheets).