V4 Form - phone validation failing intermittently
Incident Report for Formstack
Resolved
The Forms app team has not seen these key errors for over two hours now, so we are declaring this issue fully resolved.

The forms are currently fixed, however some visitors who previously saw the issue may still have cached data. The recommendation is to either:
1. Clear the browser cache through its settings page
2. Refresh the form’s cache by holding down the Shift key while refreshing the browser page
3. Use an incognito or private browsing window
Posted Mar 28, 2024 - 20:05 EDT
Monitoring
A fix has been deployed and internal checks are all passing.
Posted Mar 28, 2024 - 18:12 EDT
Identified
Formstack engineers have identified this as a caching / timing issue around the phone validation library on the live form. They are changing the way this loads to eliminate this issue.
Posted Mar 28, 2024 - 17:34 EDT
Update
Engineers are continuing to research the source of the problem.
Posted Mar 28, 2024 - 17:11 EDT
Investigating
Formstack has discovered an issue on some V4 forms where the phone number field is not completing or validating properly. When this happens, it might require the user to clear the field and re-enter the phone number. It is also possible this error will render the form inoperable.

This error is intermittent and appears to happen about half the time
Posted Mar 28, 2024 - 16:23 EDT
This incident affected: Formstack Forms (Forms (Hosted & Embedded)).