Notification emails not sending
Incident Report for Formstack
Resolved
All notification emails are sending properly. No email traffic was lost.
Posted Sep 29, 2023 - 12:57 EDT
Investigating
Formstack has been informed of an outage with the Sendgrid account responsible for sending Notification emails. These are the emails sent to Formstack users indicating that a submission has come in on their forms. Confirmation emails (to people who filled out the form) appear to be working normally.
Posted Sep 29, 2023 - 07:57 EDT
This incident affected: Formstack Forms (Email System (SendGrid)).