Google, DropBox, and HubSpot authentication reset
Incident Report for Formstack
Resolved
After extensive monitoring, we are satisfied that the fixes deployed are behaving as expected. Error incidences are very low according to logs.

We apologize for any inconvenience this may have caused, and we thank you for your patience!
Posted Aug 23, 2022 - 17:18 EDT
Update
After receiving reports of some HubSpot users being unable to re-authenticate their integrations, we made some changes to the authentication process on the back end that should allow users to re-authenticate without issue.

Please be aware that users may see a warning that they are connecting to an “unverified app”. That is because we can only verify the app after a certain number of accounts have installed it. This is not an issue, and the warning will go away naturally over time.
Posted Aug 22, 2022 - 14:07 EDT
Update
After checking the error logs this morning, we believe the fix for Google and Dropbox is in a good place, and no further action should be required by those customers that were previously impacted - including re-authenticating the integrations and re-running submissions.

We are continuing to evaluate the best path for impacted HubSpot integrations. HubSpot customers that have already successfully re-authenticated the integration should be fine moving forward. If time is of the essence, we would encourage customers who have not yet re-authenticated their HubSpot integrations to do so while we continue to work towards a possible solution..

We thank you for your continued patience and understanding!
Posted Aug 22, 2022 - 10:48 EDT
Update
We have made some progress with our solution. We were able to re-run all of the previously unauthenticated Google Sheets, Google Calendar, and Google Drive submissions that occurred during the disruption, meaning no further action is required for those forms or submissions.

We were able to re-authenticate the DropBox connections for those integrations that had not already done so. Unfortunately, those forms did not receive any submissions during the disruption, and therefore those submissions cannot be re-run through the integration. We deeply apologize for the inconvenience this has caused.

We continue to investigate the best path forward for the HubSpot integration and will update once we have more insight into whether a similar solution is possible.
Posted Aug 19, 2022 - 19:30 EDT
Update
We have deployed a fix to the Google integrations that requires no action on the part of users to re-authenticate. Any failed submissions during the outage will need to be re-run as per normal.

We are now shifting our focus to the HubSpot and DropBox integrations to determine the best path forward.
As a reminder, users who have impacted forms can always re-authenticate each impacted form integration while we continue to evaluate potential systemic solutions.
Posted Aug 19, 2022 - 13:02 EDT
Update
We are still working toward developing and releasing a solution that will simplify the re-authentication process for affected forms. At the moment, we do not have a firm ETA on when this will be available for release. We are currently focusing on a fix for the Google integrations, since this impacts the greatest number of customers. Once we have a solution in place, we will look at the HubSpot and Dropbox integrations. If the submissions on affected forms contain time-sensitive data, we recommend manual re-authentication for each form.

Thanks for your patience and understanding as we work towards a solution!
Posted Aug 19, 2022 - 10:19 EDT
Monitoring
Today, we updated API keys for a few tools that have broken the integrations with Google Sheets, Google Drive, Google Calendar, Dropbox, and Hubspot.

This means forms that use those integrations will not be able to pass that data on behalf of the customer

There are two options for those who are impacted to fix the issue:
1. Re-authenticate all forms with those integrations immediately, which will have to be done individually. To do so, navigate to the Integrations section under Settings and select the impacted integration, where you can reset the authentication under the Account Information section.
2. Our engineers have identified a solution and are working towards a release Friday, August 19 of a tool that will update all forms using an authentication after one authentication has been updated. Once that is released, customers will need to re-authenticate each integration they have, and we will ensure that change cascades to all forms using that particular authentication.

We apologize for the inconvenience that this has caused and thank you for your patience and understanding!
Posted Aug 18, 2022 - 16:26 EDT
This incident affected: Formstack Forms - Third Party Integrations (Google Sheets, HubSpot, Google Calendar, Google Drive).