Forms Worker Delay
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted Dec 09, 2021 - 05:17 EST
Monitoring
Our analytics queues are currently backed up due to yesterday's outage with AWS. Users may see delays in calculating abandonment rates within the Forms application.

We fully expect the queues to resolve on their own but users may see delays of up to 4 hours before data is available.
Posted Dec 08, 2021 - 11:29 EST
This incident affected: Formstack Forms (Main Application).