Users Unable to Login

Incident Report for Formstack

Resolved

This incident has been resolved.
Posted Dec 17, 2021 - 08:35 EST

Monitoring

We have identified an issue where some Forms and Sign customers were briefly unable to log into the application. While the issue seems to have been resolved our team will continue to monitor this event.
Posted Dec 15, 2021 - 17:23 EST
This incident affected: Formstack Forms (Main Application) and Formstack Sign (Main Application).