Docs email delivery delays
Incident Report for Formstack
Resolved
The incident is resolved, and our email service is fully operational.
Posted Feb 08, 2024 - 09:55 EST
Monitoring
The problem has been resolved, and email delivery has resumed. Newly composed emails are now dispatched promptly without any delays. All emails that were queued during the email service interruption are being sent out in chronological order, starting with the oldest. We anticipate that all backlog emails will be delivered shortly.

We apologize for any inconvenience caused by this outage, and we will continue to monitor the situation closely to ensure that email service remains fully operational.
Posted Feb 07, 2024 - 16:15 EST
Update
We're still actively working with the SendGrid team to resolve the issue, and they've assured us that this incident is their top priority. As soon as SendGrid resolves it, any pending emails will be promptly sent out.
Posted Feb 07, 2024 - 08:34 EST
Update
We are presently encountering delays in document email deliveries. We are actively collaborating with SendGrid to restore our services to fully operational status.

Email deliveries through the listed services remain unaffected and are being sent out as usual:
- Document delivery via Formstack Sign
- Custom-configured SMTP server
- Microsoft Office 365 SMTP server
- Google SMTP server
Posted Feb 06, 2024 - 09:04 EST
Identified
We are presently encountering delays in document email deliveries. We are actively collaborating with SendGrid to restore our services to fully operational status.
Posted Feb 06, 2024 - 08:08 EST
Update
We are continuing to investigate this issue.
Posted Feb 06, 2024 - 06:25 EST
Investigating
We are currently experiencing an email service disruption impacting Docs email deliveries (excl. Custom SMTP, Google SMTP and Microsoft Office 365)

Our Development teams are working to identify the root cause and implement a solution. During this time, emails send from Docs won't be delivered. Custom SMTP, Google SMTP and Microsoft Office 365 emails are not affected. We will be posting additional status updates as soon as they come in.
Posted Feb 06, 2024 - 06:25 EST
This incident affected: Formstack Documents (SendGrid API v3, SendGrid STMP).