V4 API breaking change on getValue / setValue functions
Incident Report for Formstack
Postmortem

On March 26th we updated the V4 API application to standardize the usage of the getValue and setValue functions to set and report values within fields on the form. This caused immediate issues with custom scripts as it required a new way of handling some of the values.

Today, March 28th. We released an update that will allow a customer to use either of the options. The old method is deprecated and therefore not in the current API documentation to ensure customers implementing new solutions only find the new functionality.

We will keep the app in this state (with both options available) as we change the examples to update for the new requirements.

When we do remove the old value options, we will communicate a warning to customers using the old values with a how to change before they are removed. We don’t have a timeframe for this at this time.

Posted Mar 28, 2024 - 13:52 EDT

Resolved
The Forms team released a change to the V4 API that adapted the shape of the data returned within the getValue and setValue commands. This likely broke some forms' custom code that was using these commands. Some field types were returning simple values and some were returning a labeled array. Now, with this change, all fields will return an array. Review API documentation in this support article for updated information: https://help.formstack.com/s/article/Formstack-most-recent-form-builder-V4-Api-Overview

Example of code change
// before
var someValue = "123abc";
field.setValue(someValue);
field2.setValue(field.getValue().value);

// after
var someValue = "123abc";
field.setValue({ value: someValue });
field2.setValue(field.getValue());
Posted Mar 26, 2024 - 04:00 EDT