Formstack Admin not delivering all SMS messages for two factor authentication
Incident Report for Formstack
Resolved
We have applied an update to our existing 2FA process to mitigate the errors that caused users to resend SMS 2FA requests. Thank you for your patience.
Posted Aug 14, 2023 - 11:50 EDT
Identified
We have identified an intermittent issue with Twilio delivery of SMS 2 Factor Authentication and are working on a fix.
Posted Aug 10, 2023 - 13:31 EDT
Investigating
We are currently experiencing an elevated error rate for SMS delivery. Users should attempt to resend the SMS code if they do not receive it. We are investigating the root cause of the issue.
Posted Aug 08, 2023 - 13:30 EDT
This incident affected: Formstack Forms (Main Application, Login SSO (Single sign-on)).