Delays in Documents Merge Deliveries
Incident Report for Formstack
Resolved
We are now seeing a return to normalcy with respect to queue and delivery times. Thanks for your patience and understanding!
Posted Feb 08, 2022 - 16:50 EST
Monitoring
We are seeing a decrease in the delays that were present earlier. We will update once things have returned to normal.
Posted Feb 08, 2022 - 15:49 EST
Investigating
We are currently investigating an issue that is impacting the speed of Documents merge deliveries. We will update once we have more information to share.
Posted Feb 08, 2022 - 14:38 EST
This incident affected: Formstack Documents (API & Document Generation).