Formstack Sign - Document field placement issue
Incident Report for Formstack
Resolved
The issue has been fully resolved since 6:30 AM EST. If you're still experiencing issues please contact our support.
Posted Mar 22, 2023 - 16:00 EDT
Monitoring
We identified an issue within Formstack Sign which prevented documents from being created and sent to participants, as well as, allowing participants to sign documents that were generated and sent to them.
A fix has been identified and implemented and we are monitoring results.
Users who attempted to send or sign a document in the last 10 hours will need to resend or resign documents in order to complete the process. For documents that are stalled in field placement, users will need to resume them manually.
Posted Mar 22, 2023 - 09:15 EDT
This incident affected: Formstack Sign (Main Application, Documents).