Google Sheets integration with a delayed delivery
Incident Report for Formstack
Resolved
The Google Spreadsheets integration in Formstack Forms has been restored to full functionality. Users should now see a near real-time submission to their spreadsheets as normal.
Posted Jan 24, 2023 - 13:23 EST
Monitoring
Google Spreadsheets integration has been restored and forms are submitting data as normal. There will still be a delay as the system is processing the queue of data. Will update when integration times are back to normal.
Posted Jan 24, 2023 - 10:40 EST
Investigating
The Google Sheets integration with Forms continues to perform slowly. Many submissions were processed overnight, but the queue is still quite large and moving slowly. Engineers will research the problem today and update with a fix. Please do not re-run integrations as that will only build the queue.
Posted Jan 24, 2023 - 08:12 EST
Monitoring
Forms with a Google Sheets integration will see a delayed delivery of submission data to their Google Sheet on January 23. We expect this delay to be resolved overnight and regular function to be restored by 08:00 Eastern on January 24.
Posted Jan 23, 2023 - 19:54 EST
This incident affected: Formstack Forms - Third Party Integrations (Google Sheets).