Help Center Scheduled Maintenance
Incident Report for Formstack
Resolved
We have completed Help Center maintenance (help.formstack.com) as of 7:30 PM ET today. Thank you for your patience. We are continuing additional QA testing and through Friday 1/20 but this will not impact Help Center performance. You can view the Release Notes article to see a list of changes to the Help Center. If you have any feedback or questions about the updated design, please reach out via our Help Center Feedback Form.
Release Notes: https://help.formstack.com/s/article/Formstack-Help-Center-Release-Notes
Help Center Feedback Form: https://formstack_ops.formstack.com/forms/formstack_help_center_feedback
Posted Jan 19, 2023 - 19:40 EST
Monitoring
The Help Center is undergoing routine maintenance on Thursday, January 19th, beginning at 12:30 PM ET. This only impacts the Help Center homepage and support articles on http://help.formstack.com and will not impact our applications. During this period, there may be performance issues with page loading and changes to navigation occurring in real-time. URLs to direct articles will not be affected. Upon completion of the maintenance window, we will send a follow-up announcement with more details.
Posted Jan 19, 2023 - 12:02 EST
This incident affected: Formstack Support Portal (Support Help Site).