Notification Emails
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted Aug 20, 2021 - 08:43 EDT
Update
After extensive monitoring overnight, we are confident that the issue is resolved. The email queue has returned to normal.

Thank you for your patience and understanding!
Posted Aug 20, 2021 - 08:42 EDT
Monitoring
We have identified the issue and a solution has been deployed. Please note that notification emails sent during this time were queued up and not lost. It may take a couple of hours for the queue to process, so please be patient and expect further delays while the backlog is cleared.
Posted Aug 19, 2021 - 18:20 EDT
Investigating
Notification emails are currently experiencing a disruption in service. Please bear with us while we investigate the issue. We will update once we know more.
Posted Aug 19, 2021 - 16:54 EDT
This incident affected: Formstack Forms (Email System (SendGrid)).