Documents are being held up in a field placement pending status
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 09:14 EDT
Monitoring
We have identified the issue and have implemented a solution. Formstack Sign documents are now processed with no delay. We will continue to monitor this activity.
Posted Mar 21, 2024 - 07:15 EDT
Investigating
We are currently experiencing a service disruption impacting field placement. Our Development teams are working to identify the root cause and implement a solution.
Posted Mar 21, 2024 - 06:12 EDT
This incident affected: Formstack Sign (Main Application).