Forms Responding Slowly
Incident Report for Formstack
Resolved
After monitoring the situation, we have confirmed that latency has returned to normal. Thanks for your patience and understanding!
Posted Feb 17, 2022 - 17:10 EST
Monitoring
We have identified the cause of the higher than normal latency and made some adjustments to correct. We are currently showing that latency is returning to normal levels. We will continue to monitor on our end to ensure that we continue to trend in the correct direction.
Posted Feb 17, 2022 - 16:30 EST
Investigating
We have discovered that Forms are behaving more slowly than normal. Specifically, we are seeing higher than normal levels of latency, manifesting as slowness. We will update once we have identified the cause.
Posted Feb 17, 2022 - 15:50 EST
This incident affected: Formstack Forms (Forms (Hosted & Embedded)).