AWS Latency Affecting Sign and Copilot
Incident Report for Formstack
Resolved
AWS has reported all services have been fully restored to normal operation.
Posted Jun 14, 2023 - 09:02 EDT
Monitoring
AWS has reported the root issue has been identified and a resolution has been applied. Services are beginning to recover to normal operations. AWS is continuing to monitor service recovery across all services.
Posted Jun 13, 2023 - 16:54 EDT
Identified
AWS has reported system degradation that is affecting some services utilized within Formstack Sign and Copilot. The issue has been identified and Amazon is working on implementing the resolution expediently. Our engineering teams continue to monitor until the services are fully restored.

https://health.aws.amazon.com/health/status
Posted Jun 13, 2023 - 15:52 EDT
This incident affected: Formstack Sign (Main Application).