Possible merge delays

Incident Report for Formstack

Resolved

This incident has been resolved.
Posted May 28, 2025 - 09:45 EDT

Investigating

Engineers have observed delays processing some merge requests. They are looking into a solution and will update this page soon. No customer action is required at this time.
Posted May 28, 2025 - 08:54 EDT
This incident affected: Formstack Documents (API & Document Generation).